"Share object taichi_core import failed" with CUDA flavor on Windows

Hi, I’m a long time lurker who’s been waiting for CUDA support on Windows.

I installed taichi by:
py -m pip install taichi-nightly-cuda-10-1

Here’s the error and the packages pip shows:

This same result was obtained on my work machine with taichi 0.5.5 as on my home machine now with taichi 0.5.6. Both are Windows 10.

Pastebin was needed because the “preformatted” option on the forum software here doesn’t work- I guess it doesn’t like Windows newlines?

1 Like

Hi @JTT,

Have you tried “If you are on Windows, please consider installing “Microsoft Visual C++ Redistributable” (https://aka.ms/vs/16/release/vc_redist.x64.exe)”?

Sorry, I neglected to mention that I tried installing the VC++ runtime on both machines, with no change in results. In one case it was a repair, and the other, a fresh install.

I had the same problem. I replaced taichi_core.pyd with the CPU version of taichi_core.pyd and it runs. This bug should be related to cuda, but PyTorch is fine.