`pip install taichi` would only install version 0.7.10 and not the latest (0.7.32)

I was aiming to try the latest version of taichi_elements, but the examples complain that AttributeError: 'Matrix' object has no attribute 'get_scalar_field'. I thought this could go away if I updated my version of taichi, which is currently 0.7.10 (python 3.7).

However, pip install taichi -U would only install v0.7.10, and pip install -Y taichi==0.7.32 would complain that the package does not exist.

I tried creating a fresh conda environment, but the problem was still the same: pip would only install v0.7.10.

How can I install the latest version? (Mac user)
Thank you!

Sorry, I could not reproduce your problem and I could install the new version taichi on my Mac.

Could you uninstall the old version taichi(0.7.10) and reinstall taichi==0.7.32 with

python3 -m pip install taichi=0.7.32

And did you ever compile and build taichi source code on your Mac?

1 Like

@r03ert0 quick question: is your python3.7 64bit or 32bit? (note taichi only supports 64bit python)
If reinstalling doesn’t solve your problem, would you mind share a few commands how you set up from a fresh conda environment? Thanks!

1 Like

Hi @r03ert0 we probably figured out the issue, is your macos version >= 10.15? Currently our pypi release only supports up to 0.7.10 for 10.14. We’re considering extending the pypi support for 10.14 but it might take some time.


That’s the problem. I’m using 10.14 :disappointed_relieved:
I may need to finally take the big leap and switch to 10.15…
thank you @ailing!

1 Like

fyi we’ve added 10.14 whls in pypi :wink: (some metal functionalities might be limited tho :stuck_out_tongue: